|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- log a warning message for an audio device
#include <sys/audio/audio_driver.h> void audio_dev_warn(audio_dev_t *adev, const char *fmt, ...);
pointer to an audio device allocated with audio_dev_alloc(9F). This parameter can be NULL if no suitable device pointer is available.
format of message to be displayed
Solaris DDI specific (Solaris DDI)
The audio_dev_warn() function is a convenience wrapper that sends a message to the system console or logs using cmn_err(9F) with a level of CE_WARN. It also prefixes the message with information identifying the device if adev is not NULL.
The format should not contain any trailing newlines, as the newline will be appended by cmn_err() automatically. Unlike cmn_err(), however, no special handling of the first character of the format string is performed.
This function may be called in any context.
See attributes(5) for descriptions of the following attributes: