|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- validate the Card Information Structure (CIS)
#include <sys/pccard.h> int32_t csx_ValidateCIS(client_handle_t ch, cisinfo_t *ci);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cisinfo_t structure.
This function validates the Card Information Structure (CIS) on the PC Card in the specified socket.
The structure members of cisinfo_t are:
uint32_t Socket; /* socket number to validate CIS on */ uint32_t Chains; /* number of tuple chains in CIS */ uint32_t Tuples; /* total number of tuples in CIS */
The fields are defined as follows:
Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number.
This field returns the number of valid tuple chains located in the CIS. If 0 is returned, the CIS is not valid.
This field is a Solaris-specific extension and it returns the total number of tuples on all the chains in the PC Card's CIS.
No CIS on PC Card or CIS is invalid.
No PC Card in socket.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA