|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- inform a process that an event has occurred
#include <sys/poll.h> void pollwakeup(struct pollhead *php, short event);
Architecture independent level 1 (DDI/DKI).
Pointer to a pollhead structure.
Event to notify the process about.
The pollwakeup() function wakes a process waiting on the occurrence of an event. It should be called from a driver for each occurrence of an event. The pollhead structure will usually be associated with the driver's private data structure associated with the particular minor device where the event has occurred. See chpoll(9E) and poll(2) for more detail.
The pollwakeup() function can be called from user, interrupt, or kernel context.
Driver defined locks should not be held across calls to this function.