|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- enable a queue
#include <sys/stream.h> #include <sys/ddi.h> void qenable(queue_t *q);
Architecture independent level 1 (DDI/DKI).
Pointer to the queue to be enabled.
The qenable() function adds the queue pointed to by q to the list of queues whose service routines are ready to be called by the STREAMS scheduler.
The qenable() function can be called from user, interrupt, or kernel context.
See the dupb(9F) function page for an example of the qenable().