|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- indicate which network interface packets are sent
#include <sys/neti.h> phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address, struct sockaddr *nexthop);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
network address to find a path out of the machine for.
pointer to the sockaddr structure in which to store the address of the next hop. If this information is not required, the value NULL may be passed instead.
The net_routeto() function indicates which network interface packets destined for a particular address would be sent out of, according to the systems network routing tables. If next is supplied as a non-NULL pointer, the IP address of the nexthop router to be used is returned in it.
The net_routeto() function returns:
The network protocol does not support this function.
This function cannot find a route for the address given.
Indicates which network interface can be used to reach the given address.
The net_routeto() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: