|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- make device number from major and minor numbers
#include <sys/types.h> #include <sys/mkdev.h> #include <sys/ddi.h> dev_t makedevice(major_t majnum, minor_t minnum);
Architecture independent level 1 (DDI/DKI).
Major device number.
Minor device number.
The makedevice() function creates a device number from a major and minor device number. makedevice() should be used to create device numbers so the driver will port easily to releases that treat device numbers differently.
The device number, containing both the major number and the minor number, is returned. No validation of the major or minor numbers is performed.
The makedevice() function can be called from user, interrupt, or kernel context.