|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- parse the Software Interleaving tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_SWIL(client_handle_t ch, tuple_t *tu, cistpl_swil_t *pt);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_swil_t structure which contains the parsed CISTPL_SWIL tuple information upon return from this function.
This function parses the Software Interleaving tuple, CISTPL_SWIL, into a form usable by PC Card drivers.
The CISTPL_SWIL tuple provides the software interleaving of data within a partition on the card.
The structure members of cistpl_swil_t are:
The fields are defined as follows:
This field provides the software interleaving for a partition.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA