|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- copy from a buf(9S) into a driver buffer
#include <sys/types.h> #include <sys/buf.h> int bp_copyin(struct buf *bp, void *driverbuf, offset_t offset, size_t size);
Architecture independent level 1 (DDI/DKI).
Pointer to the buffer header structure to copy from.
Driver buffer to copy to.
Offset into bp where to start copying.
Size of copy.
The bp_copyin() function copies size bytes into the memory associated with bp to the destination driver buffer driverbuf. The offset only applies to bp.
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages.
The bp_copyin() function can be called from user or kernel context only.