|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- disable a set of instances
#include <sys/neti.h> void net_instance_unregister(net_instance_t *instances);
Solaris DDI specific (Solaris DDI).
must be a pointer returned by net_instance_alloc(9F).
The net_instance_unregister() function removes the set of instances that were previously registered with the net_instance_register() function.
If the net_instance_unregister() function succeeds, 0 is returned. Otherwise, an error indicating the problem encountered.
The net_instance_unregister() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: