|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- parse the Battery Replacement Date tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_BATTERY(client_handle_t ch, tuple_t *tu, cistpl_battery_t *cb);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_battery_t structure which contains the parsed CISTPL_BATTERY tuple information upon return from this function.
This function parses the Battery Replacement Date tuple, CISTPL_BATTERY, into a form usable by PC Card drivers.
The CISTPL_BATTERY tuple is an optional tuple which shall be present only in PC Cards with battery-backed storage. It indicates the date on which the battery was replaced, and the date on which the battery is expected to need replacement. Only one CISTPL_BATTERY tuple is allowed per PC Card.
The structure members of cistpl_battery_t are:
uint32_t rday; /* date battery last replaced */ uint32_t xday; /* date battery due for replacement */
The fields are defined as follows:
This field indicates the date on which the battery was last replaced.
This field indicates the date on which the battery should be replaced.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA