|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- extract the params for PF and VF drivers
#include <sys/sunddi.h> int pci_param_get_ioctl(dev_info_t *dip, intptr_t arg, int mode, pci_param_t *php);
Pointer to dev_info structure.
The device driver is expected to pass the arguments they receive in their ioctl call directly to this interface.
A pointer to a (void *) param handle.
The pci_param_get_ioctl() function extracts the params from the arg argument and returns a pci_param_t handle in php. Drivers should call pci_param_free(9F) to free the param handle returned in this call after retrieving params from the handle. Drivers are expected to use pci_plist_get(9F) and pci_plist_getvf(9F) on the param handle to get the name-value list for the PF and VF devices.
A valid param handle pointer php is returned
The call failed to extract params from arg.
The pci_param_get() function can be called from kernel non-interrupt context.
See attributes(5) for descriptions of the following attributes: