|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- determine the MTU of a given network interface
#include <sys/neti.h> int net_getmtu(const net_data_t net, const phy_if_t ifp);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
The net_getmtu() function receives information about the current MTU of a network interface. The value returned from this function call should not be cached as the MTU of a network interface since it is not guaranteed to be constant.
The net_getmtu() function returns -1 if the network protocol does not support this feature and otherwise returns the current MTU of the network interface.
The net_getmtu() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: