|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- accept or discard a deferred connection
#include <sys/sockfilter.h> void sof_newconn_ready(sof_handle_t hdl);
void sof_newconn_close(sof_handle_t hdl);
per-socket filter handle
The sof_newconn_ready() function informs the framework that the deferred connection should be made available to the application via accept(3SOCKET). In the presence of multiple filters, the connection will only be made available once all filters have called sof_newconn_ready().
The sof_newconn_close() function causes the connection to be closed immediately. The normal close sequence will be executed, and filters will therefore observe a SOF_EV_CLOSING event (see sofop_notify(9E)) followed by a call to sofop_detach(9E).
Calling either sof_newconn_ready() or sof_newconn_close() on a connection that is not deferred has no effect.
The sof_newconn_ready() and sof_newconn_close() functions can be called from any context
See attributes(5) for descriptions of the following attributes: