|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- provides disk and SCSI tape support for HP Smart Array controllers
The cpqary3 module provides low-level interface routines between the common disk I/O subsystem and the HP SMART Array controllers. The cpqary3 driver provides disk and SCSI tape support for the HP Smart Array controllers.
Please refer to the cpqary3 Release Notes, for the supported HP Smart Array Controllers and Storage boxes.
Each of the controller should be the sole initiator on a SCSI bus. Auto configuration code determines if the adapter is present at the Configured address and what types of devices are attached to it.
Use the Array Configuration Utility to configure the controllers. Each controller can support up to 32 logical volumes. In addition, each controller supports up to a maximum of 28 connected SCSI tape drives. With 1.90 and later versions of cpqary3 driver, HP Smart Array SAS controllers, having Firmware Revision 5.10 or later, support 64 logical drives. This firmware also supports Dual Domian Multipath configurations.
The driver attempts to initialize itself in accordance with the information found in the configuration file, /kernel/drv/cpqary3.conf.
The following properties can be specified in /kernel/drv/cpqary3.conf:
The time in seconds between checks of the controller heartbeat. The default is 180 seconds. A value of 0 disables the heartbeat check. When a controller fault recovery method other than none is used, reducing the heart beat check interval can reduce the time that it takes for the driver to detect a controller fault. The smallest recommended interval is 5 seconds.
The controller fault recovery method to use. When the controller or firmware becomes unresponsive, the driver attempts to recover. The following recovery methods are available:
The driver does not attempt recovery. This is the default.
I/O requests pending at the controller at the time of the fault does not complete. Applications or other parts of the system that are waiting on this I/O can become unresponsive. Future I/O requests fail. This is the historical behavior of the driver. A reboot is required to recover user of the failed controller. This method must be used for controllers with RAID5 or above logical volumes.
The driver attempts to quarantine the controller. If quarantine is successful, pending I/O requests are timed out. Applications or other parts of the system receive I/O errors. Future I/O requests to the controller continues to fail. Redundant controllers can be used with software RAID, such as ZFS, to provide fault tolerance. A reboot is required to recover full use of the failed controller.
Do not use this method with controllers with RAID5 or above logical volumes. When using quarantine, HP recommends the use of a filesystem that can verify data integrity, such as ZFS. This method is only supported for P410 and P410i controllers, and requires firmware version 5.00 or higher.
Configuration file for CPQary3
Configuration file for sd
Configuration file for st
Block special file names for disk device
Character special file names for disk device
Special file names for SCSI tape devices
cpqary3 Release Notes
The Smart Array controllers supported by the current version of the cpqary3 driver do not support format unit SCSI command. Therefore, selecting the format option under the format utility main menu is not supported. In addition, the repair option under format utility main menu is not supported as this operation is not applicable to Logical volumes connected to the supported Smart Array controllers.
The names of the block files can be found in /dev/dsk. The names of the raw files can be found in /dev/rdsk.