|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- driver for VIA Rhine fast Ethernet controllers
The vr Fast Ethernet driver is GLD based and supporting the VIA Rhine family of Fast Ethernet adapters:
pci1106,3043 VIA VT86C100A Fast Ethernet pci1106,3065 VT6102 VIA Rhine II pci1106,3106 VT6105 VIA Rhine III pci1106,3053 VT6105 VIA Rhine III Management Adapter
The vr driver supports IEEE 802.3 auto-negotiation, flow control and VLAN tagging.
The default configuration is autonegotiation with bidirectional flow control. The advertised capabilities for autonegotiation are based on the capabilities of the PHY.
You can set the capabilities advertised by the vr controlled device using dladm(1M). The driver supports a number of parameters, the names of which begin with en_ (enabled). Each of these boolean parameters determines if the device advertises that mode of operation when the hardware supports it.
The adv_autoneg_cap parameter controls whether auto-negotiation is performed. If adv_autoneg_cap is 0, the driver selects the speed/duplex combination from the first non-zero parameter from this list:
en_100fdx_cap 100Mbps full duplex en_100hdx_cap 100Mbps half duplex en_10fdx_cap 10Mbps full duplex en_10hdx_cap 10Mbps half duplex
All capabilities default to enabled. Changing any capability parameter causes the link to go down while the link partners renegotiate the link using the newly changed capabilities.
The vr driver does not support asymmetric flowcontrol. VT86C100A and Rhine II adapters are not capable of transmitting flowcontrol messages
Special character device
64-bit device driver (SPARC)
64-bit device driver (x86)
See attributes(5) for a description of the following attributes:
STREAMS Programmer's Guide
Network Interfaces Programmer's Guide
IEEE 802.3ae Specification - 2002