|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- ConnectX MT25408/MT25418/MT25428 InfiniBand (IB) Driver
The hermon driver is an IB Architecture-compliant implementation of an HCA, which operates on the Mellanox MT25408, MT25418 and MT25428 InfiniBand ASSPs using host memory for context storage rather than locally attached memory on the card. Cards based on these ASSP's utilize the PCI-Express I/O bus. These ASSP's support the link and physical layers of the InfiniBand specification while the ASSP and the driver support the transport layer.
The hermon driver interfaces with the InfiniBand Transport Framework (IBTF) and provides an implementation of the Channel Interfaces that are defined by that framework. It also enables management applications and agents to access the IB fabric.
64–bit ELF kernel module. (x86)
64-bit ELF Kernel Module. (SPARC)
Driver configuration file.
See attributes(5) for descriptions of the following attribute:
In addition to being logged, the following messages may appear on the system console:
There was a failure in the boot process of the hermon ASSP and the only function that can be performed is to re-flash firmware on the ASSP. (i represents the instance of the hermon device number.)
The ASSP could not boot into either operational (HCA) mode or into maintenance mode. The device is inoperable. (I represents the instance of the hermon device number.)
A port state change event occurred, but the port number in the message does not exist on this HCA. This message also indicates the port number that was in the port state changed.
The driver has been removed from the system and the HCA is no longer available for transfer operations.
A port up asynchronous event has occurred. (I represents the instance of the Hermon device number while m represents the port number on the Hermon device.
A port up asynchronous event has occurred. Similar to port up event.
A internal firmware command failed to execute.