|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- Intel 1Gb PCI Express NIC Driver
The igb Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on Intel 82575/82576 Gigabit Ethernet controllers.
The igb driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.
The igb driver and hardware support auto-negotiation, a protocol specified by the 1000 Base-T standard. Auto-negotiation allows each device to advertise its capabilities and discover those of its peer (link partner). The highest common denominator supported by both link partners is automatically selected, yielding the greatest available throughput, while requiring no manual configuration. The igb driver also allows you to configure the advertised capabilities to less than the maximum (where the full speed of the interface is not required), or to force a specific mode of operation, irrespective of the link partner's advertised capabilities.
The igb driver also supports the SRIOV capability on Intel 82576 Gigabit Ethernet controller. In SRIOV enabled mode, it supports the Physical Function of the controller.
By default, the igb driver performs auto-negotiation to select the link speed and mode. Link speed and mode can be any one of the following, as described in the IEEE 803.2 standard:
1000 Mbps, full-duplex.
100 Mbps, full-duplex.
100 Mbps, half-duplex.
10 Mbps, full-duplex.
10 Mbps, half-duplex.
The auto-negotiation protocol automatically selects speed (1000 Mbps, 100 Mbps, or 10 Mbps) and operation mode (full-duplex or half-duplex) as the highest common denominator supported by both link partners.
Alternatively, you can set the capabilities advertised by the igb device using ndd(1M). The driver supports a number of parameters whose names begin with adv_ (see below). Each of these parameters contains a boolean value that determines if the device advertises that mode of operation. For example, the adv_1000fdx_cap parameter indicates if 1000M full duplex is advertised to link partner. The adv_autoneg cap parameter controls whether auto-negotiation is performed. If adv_autoneg_cap is set to 0, the driver forces the mode of operation selected by the first non-zero parameter in priority order as shown below:
(highest priority/greatest throughput) en_1000fdx_cap 1000Mbps full duplex en_100fdx_cap 100Mbps full duplex en_100hdx_cap 100Mbps half duplex en_10fdx_cap 10Mbps full duplex en_10hdx_cap 10Mbps half duplex (lowest priority/least throughput)
All capabilities default to enabled. Changing any capability parameter causes the link to go down while the link partners renegotiate the link speed/duplex using the newly changed capabilities.
In SRIOV mode, the following device specific parameters are exported by the igb driver to supprot SR-IOV feature.
This is a read-only parameter describing the maximum number of VFs that can be configured. A value of 7 is exported to override the information that is found in PCI config space of the 82576 device. This difference is due to the fact that igb driver utilizes hardware resources to provide a functional PF device along with VFs. This parameter enables external management software to limit the number of configured VFs to be 7 or less.
This is a read-only parameter describing the maximum number of VLAN filters supported for PF and VFs. As the 82576 supports 32 VLAN filters for PF and VFs all together, a value of 32 is exported. This parameter allows external management software entities to limit the number of VLAN filters configured to be with the supported limit.
This is a read-only parameter describing the maximum MTU allowed for a VF. A value of 9216 is exported to indicate the 82576 VF hardware limit. This parameter allows external management software to limit the maximum VF MTU setting to be within the described limit.
This is a read-only parameter describing the hardware attribute that vlan IDs and port vlan ID are mutual exclusive on a 82576 device. Users cannot set vlan IDs successfully when port vlan ID has been set. Vice versa, users cannot set port vlan ID successfully when vlan IDs have been set.
This is a tunable parameter that allows the reservation of unicast mac-address slots to a PF or a VF. A total of 24 unicast mac-address slots are present in a 82576 device instance, out which one mac-address slot for the PF and each VFs is always reserved. The rest of the unicast mac-address slots can be reserved for the PF or VFs through this parameter. If not, the rest unicast mac-address slots are shared and allocated on first come first serve basis.
Special character device
64–bit device driver (x86)
64–bit device driver (SPARC)
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide