|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- SiS900 series Fast Ethernet device driver
The sfe driver is a loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface dlpi(7P) on Silicon Integrated Systems 900 series Fast Ethernet controllers.
The relevant fields returned as part of a DL_INFO_ACK response are:
Maximum SDU is 1500.
Minimum SDU is 0.
The dlsap address length is 8.
MAC type is DL_ETHER.
SAP length is -2. The 6–byte physical address is followed immediately by a 2–byte SAP.
Service mode is DL_CLDLS.
Broadcast address is the 6-byte Ethernet broadcast address (ff:ff:ff:ff:ff:ff).
If the SAP provided is zero, then IEEE 802.3 mode is assumed and outbound frames will have the frame payload length written into the type field. Likewise, inbound frames with a SAP between zero and 1500 are interpreted as IEEE 802.3 frames and delivered to any streams that are bound to SAP zero (the 802.3 SAP).
Enables the 100 Base TX full-duplex link option. (This is generally the fastest mode if both link partners support it. Most modern equipment supports this mode.)
Enables the 100 Base TX half-duplex link option. (Typically used when the link partner is a 100 Mbps hub.)
Enables the 10 Base-T full-duplex link option. (This less-frequently used mode is typically used when the link partner is a 10 Mbps switch.)
Enables the 10 Base-T half-duplex link option. (This is the fall-back when no other option is available. It is typically used when the link partner is a 10 Mbps hub or is an older network card.)
See attributes(5) for a description of the following attributes:
Special character device
64-bit driver binary (x86)
64-bit driver binary (SPARC)
IEEE 802.3 — Institute of Electrical and Electronics Engineers, 2002