|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- clear locks held on behalf of an NFS client
/usr/sbin/clear_locks [-s] hostname
The clear_locks command removes all file, record, and share locks created by the hostname and held on the current host, regardless of which process created or owns the locks.
This command can be run only by the super-user.
This command should only be used to repair the rare case of a client crashing and failing to clear held locks. Clearing locks held by an active client may cause applications to fail in an unexpected manner.
Remove all locks created by the current machine and held by the server hostname.
The following operands are supported:
name of host server
If not root.
If unable to contact server (RPC).
See attributes(5) for descriptions of the following attributes: