|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- change operational status of interfaces within a multipathing group
/usr/sbin/if_mpadm -d interface_name
/usr/sbin/if_mpadm -r interface_name
Use the if_mpadm utility to change the operational status of interfaces that are part of an IP multipathing group. If the interface is operational, you can use if_mpadm -d to detach or off-line the interface. If the interface is off-lined, use if_mpadm -r to revert it to its original state.
When a network interface is off-lined, all network access fails over to a different interface in the IP multipathing group. Any addresses that do not failover are brought down. Network access includes unicast, broadcast, and multicast for IPv4 and unicast and multicast for IPv6. Addresses marked with IFF_NOFAILOVER do not failover. They are marked down. After an interface is off-lined, the system will not use the interface for any outbound or inbound traffic, and the interface can be safely removed from the system without any loss of network access.
The if_mpadm utility can be applied only to interfaces that are part of an IP multipathing group.
The if_mpadm utility supports the following options:
Detach or off-line the interface specified by interface_name.
Reattach or undo the previous detach or off-line operation on the interface specified by interface_name. Unless the -d option was used to detach or off-line the interface, this option will fail.
Example 1 Detaching an Interface
Use the following command to off-line or detach the interface. All network access will failover from hme0 to other interfaces in the same IP multipathing group. If no other interfaces are in the same group, the operation will fail.
example% if_mpadm -d hme0
Example 2 Reattaching an Off-line Interface
Use the following command to undo the previous operation. Network access will failback to hme0.
example% if_mpdadm -r hme0
See attributes(5) for descriptions of the following attributes:
off-line failed as there is no other functional interface available in the multipathing group for failing over the network access.
Description: This message means that other interfaces in the group are failed over already or the multipathing configuration was not suitable for completing a failover.
off-line cannot be undone because multipathing configuration is not consistent across all the interfaces in the group.
Description: This message means that some interfaces in the IP multipathing group are not configured consistently with other interfaces in the group, for example, one of the interfaces in the group does not have an IFF_NOFAILOVER address.