|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- firmware query and update utility
/usr/sbin/fwflash [-l [-c device_class | ALL ]] | [-v] | [-h]
fwflash [-f file | -r file] [-y] [-d dev_spec]
The fwflash command writes a binary image file to flash devices of an HBA or HCA device. It also provides the ability to read firmware to a file if supported by the device. Because changing the firmware in a device can have significant impact on the stability of a system, only users with the privilege All are allowed to execute this command. Users authorized to run fwflash can be granted the “Firmware Flash Update” Rights Profile.
The first form of the command, above, provides information about devices. It lists all devices currently available on the system and supported by fwflash for firmware upgrade. You can filter the list operation, to display only specified classes of devices. The second form of the command provides the operations to read or write the firmware images to specific devices.
The following options are supported:
An optional parameter, valid only when used with the -l option. This option causes the command to list only devices of a specific class type. Currently supported classes are IB or ALL. If -c is not specified for the -loption, the class defaults to ALL.
The dev_spec is an identifier of the device that the user wants to modify with the -for -r operation. dev_spec can be either the absolute path name as displayed in the -l listing or as the device number from the same listing. If the device cannot be found, the command fails.
Specify the path to a binary firmware file you want to write to the device. fwflash will verify that the file is a valid firmware binary for the dev_spec specified. If it is not, the command fails with an appropriate error message.
List the command line help for fwflash.
List the devices on a system available for firmware upgrade and display information specific to each device or device class.
For InfiniBand (IB) devices, the list operation displays the guids (Globally Unique Identifier) currently set for the HCA, as well as the current firmware revision installed. There are four separate guids on the HCA; two of them can be set with the same value.
Specify the path to a file to create when reading the firmware from the device. The -f and -r options are mutually exclusive.
Output fwflash version information and exit.
Valid during an -f or -r operation, causes fwflash not to prompt for confirmation during operation and operate non-interactively.
Example 1 Entering Command Without Arguments
The following command shows fwflash when the command is entered without arguments.
example# fwflash Usage: fwflash [-l [-c <device_class> | ALL]] | [-v] | [-h] [-f <file> | -r <file>] [-y] [-d <dev_spec>]
Example 2 Listing Devices Available to Flash
The following command lists the devices available to be flashed.
example# fwflash -l List of available devices: Device, /devices/pci@0,0/pci8086,3595@2/pci8086,32a@0,2/\ pci15b3,5a46@c/pci15b3,5a44@0:devctl Class [IB] GUID: System Image - 0002c901081e33b3 Node - 0000000000003446 Port 1 - 0002c901081e33b1 Port 2 - 0002c901081e33b2 Firmware revision: 3.3.0002 No HW information available Device, /devices/pci@0,0/pci8086,3597@4/pci15b3,6278@0:devctl Class [IB] GUID: System Image - 0002c9010a99e3b3 Node - 0002c9010a99e3b0 Port 1 - 0002c9010a99e3b1 Port 2 - 0002c9010a99e3b2 Firmware revision: 4.8.00c8 Product : MTLP25208-CF256T (Lion cub) PSID : MT_00B0000001
Example 3 Flash Upgrading an IB HCA Device
The following command flash upgrades an IB HCA device.
example# fwflash -f ./version.3.2.0000 -d 0 About to update firmware on: /devices/pci@1d,700000/pci@1/pci15b3,5a44@0:devctl Continue (Y/N): Y Updating . . . . . . . . . . . . Done. New image will be active after the system is rebooted.
Note that you are prompted before the upgrading proceeds.
The following command adds the -y option to the preceding command.
example# fwflash -y -f ./version.3.2.0000 -d 0 About to update firmware on: /devices/pci@1d,700000/pci@1/pci15b3,5a44@0:devctl Updating . . . . . . . . . . . . Done. New image will be active after the system is rebooted.
Example 4 Reading Device Firmware to File
The command shown below reads the device firmware to a file. The command uses the -y option so that read occurs without prompting.
example# fwflash -y -r /firmware.bin -d 1 About to read firmware on: /devices/pci@0,0/pci8086,3596@3/pci15b3,6278@0:devctl to filename: /firmware.bin Reading . . . Done.
The fwflash command returns the following values:
See attributes(5) for descriptions of the following attributes:
The fwflash command supports IB class HCA cards containing either the AMD or the Intel parallel flash parts. The tavor(7D) HCA driver is required.