|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- user interface to the NAT subsystem
ipnat [-CdFhlnRrsv] -f filename
The ipnat utility opens a specified file (treating - as stdin) and parses it for a set of rules that are to be added or removed from the IP NAT.
If there are no parsing problems, each rule processed by ipnat is added to the kernel's internal lists. Rules are appended to the internal lists, matching the order in which they appear when given to ipnat.
ipnat's use is restricted through access to /dev/ipauth, /dev/ipl, and /dev/ipstate. The default permissions of these files require ipnat to be run as root for all operations.
ipnat's use is restricted through access to /dev/ipnat. The default permissions of /dev/ipnat require ipnat to be run as root for all operations.
The following options are supported:
Delete all entries in the current NAT rule listing (NAT rules).
Turn debug mode on. Causes a hex dump of filter rules to be generated as it processes each one.
Delete all active entries in the current NAT translation table (currently active NAT mappings).
Parse specified file for rules to be added or removed from the IP NAT. filename can be stdin.
Print number of hits for each MAP/Redirect filter.
Show the list of current NAT table entry mappings.
Prevents ipf from doing anything, such as making ioctl calls, which might alter the currently running kernel.
Disable both IP address-to-hostname resolution and port number-to-service name resolution.
Remove matching NAT rules rather than add them to the internal lists.
Retrieve and display NAT statistics.
Turn verbose mode on. Displays information relating to rule processing and active rules/table entries.
Link to IP Filter pseudo device.
Special file that provides access to virtual address space.
Location of ipnat startup configuration file.
Contains numerous IP Filter examples.
See attributes(5) for descriptions of the following attributes:
To view license terms, attribution, and copyright for IP Filter, the default path is /usr/lib/ipf/IPFILTER.LICENCE. If the Solaris operating environment has been installed anywhere other than the default, modify the given path to access the file at the installed location.