|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- create NIS (YP) to LDAP configuration files
/usr/lib/netsvc/yp/inityp2l [-m mapping_file_name] [-c config_file_name]
The inityp2l utility assists with creation of the NISLDAPmapping and ypserv files. See NISLDAPmapping(4) andypserv(4). inityp2l examines the NIS maps on a system. and through a dialogue with the user, determines which NIS to (and from) LDAP mappings are required. A NISLDAPmapping file is then created based on this information. The utility asks users about their LDAP server configuration and a ypserv file is created based on this information.
The inityp2l utility handles mappings for standard NIS maps and the auto.* series of maps. If requested, it creates default mappings for custom maps, with each map entry represented as a single DIT string. inityp2l does not handle full custom mapping, but if requested, inityp2l will insert comments into the NISLDAPmapping file that indicate where these should be added.
To write to the NISLDAPmapping or ypserv files is potentially dangerous. inityp2l warns the user and asks for confirmation before:
it overwrites either file
it writes to the default NISLDAPmapping file location, if this file did not previously exist. This is important because the existence of a file in this location causes NIS components to work NIS to LDAP (N2L) mode when next restarted, rather than to traditional NIS mode.
inityp2l assists with rapid creation of a simple N2L configuration files. It is not a general purpose tool for the management of these files. An advanced user who would like to maintain the files or use custom mappings should examine the output of inityp2l and customize it by using a standard text editor.
inityp2l supports the following options:
Specify the name of the generated ypserv file. The default location is described in Files.
Specify the name of the generated NISLDAPmapping file. The default is described in Files.
The directory to be searched for candidate domains (/var/yp/*) and NIS maps (/var/yp/*/*)
The default location for the generated NISLDAPmapping file
The default location for the generated ypserv file
See attributes(5) for descriptions of the following attributes: