|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- configure a system's host parameters
/usr/sbin/hostconfig -p protocol [-d] [ -h] [-n] [-v] [-i interface] [-f hostname]
The hostconfig program uses a network protocol to acquire a machine's host parameters and set these parameters on the system.
The program selects which protocol to use based on the argument to the required -p flag. Different protocols may set different host parameters. Currently, only one protocol (bootparams) is defined.
The following options are supported:
Enable debug output.
Run the protocol as if this machine were named hostname.
Echo the received hostname to stdout, rather than setting hostname using the system name directly.
Use only the named network interface to run the protocol.
Run the network protocol, but do not set the acquired parameters into the system.
Run hostconfig using protocol. Currently, only one protocol (bootparams) is available. This option is required.
Specifying the -p bootparams option uses the whoami call of the RPC bootparams protocol. This sets the system's hostname, domainname, and default IP router parameters.
Enable verbose output.
Example 1 Configuring Host Parameters with Verbose Output
The following command configures a machine's host parameters using the whoami call of the RPC bootparams protocol with a verbose output.
example# hostconfig -p bootparams -v
Example 2 Displaying Host Parameters
The following command displays the parameters that would be set using the whoami call of the RPC bootparams protocol.
example# hostconfig -p bootparams -n -v
Example 3 Configuring Host Parameters Less the System Name
The following command configures a machine's host parameters, less the system name, using the whoami call of the RPC bootparams protocol.
example# hostconfig='hostconfig -p bootparams -h'
See attributes(5) for descriptions of the following attributes: