|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- detach a name from a STREAMS-based file descriptor
The fdetach command detaches a STREAMS-based file descriptor from a name in the file system. Use the path operand to specify the path name of the object in the file system name space, which was previously attached. See fattach(3C).
The user must be the owner of the file or a user with the appropriate privileges. All subsequent operations on path will operate on the underlying file system entry and not on the STREAMS file. The permissions and status of the entry are restored to the state they were in before the STREAMS file was attached to the entry.
The following operands are supported:
Specifies the path name of the object in the file system name space, which was previously attached.
See attributes(5) for descriptions of the following attributes: