|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- close down the FTP Servers at a given time
ftpshut [-V] [-v] [-l min] [-d min] time [warning-message]...
The ftpshut command provides an automated shutdown procedure that the superuser can use to notify FTP users when the FTP Server is shutting down.
Ten minutes before shutdown, or immediately if the value of time is less than ten minutes, any new FTP Server connections will be disabled. You may adjust the shutdown of new FTP Server connections by means of the -l option.
Five minutes before shutdown, or immediately if the value of time is less than five minutes, all current FTP connections will be disconnected. You may adjust the shutdown of current FTP connections by means of the -d option.
The ftpshut command creates shutdown message files that the FTP Server uses to determine when to shutdown. Separate shutdown message files are created in the anonymous and virtual host FTP Server areas, in addition to the system wide shutdown message file. Once the shutdown occurs, the server continues to refuse connections until the appropriate shutdown message file is removed. This normally is done by using the ftprestart(1M) command. The location of the shutdown message file is specified by the shutdown capability in the ftpaccess file.
The following magic cookies are available:
The time system is going to shut down.
The time new connections will be denied.
The time current connections will be dropped.
The current working directory.
The maintainer's email address as defined in the ftpaccess file.
The free space in the partition of CWD, in kilobytes.
The local host name.
The maximum allowed number of users in this class.
The current number of users in this class.
The remote host name.
The local time (form Thu Nov 15 17:12:42 1990).
The username given at login time.
The ftpshut command supports the following options:
Display program copyright and version information, then terminate.
The time ahead of shutdown, in minutes, that existing connections will be disconnected upon completion of their current or next (if idle) FTP request.
The time ahead of shutdown, in minutes, that new connections will be refused.
Verbose. Output the pathname of the shutdown message files created.
The ftpshut command supports the following operands:
The time at which ftpshut will bring the FTP Servers down. time can have a value of now, which indicates an immediate shutdown. Alternatively, time can specify a future time in one of two formats: +number or HHMM. The first form brings the FTP Server down in number minutes. The second brings the FTP Server down at the time of day indicated, using a 24-hour clock format. When using the absolute time format, you can only specify times between now and 23:59.
The message to display that warns of the imminent shutdown. The warning-message will be formatted at 70 characters wide. ftpshut knows the actual string length of the magic cookies. If no warning-message is supplied, the default message “System shutdown at %s” is used.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes: