|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- file compression utility
/sbin/fiocompress -c [-m] [-b block_size] input_file output_file
/sbin/fiocompress -d input_file output_file
The fiocompress utility is a file compression tool that works together with the dcfs(7FS) file system to perform per-file compression. You can use fiocompress to decompress a compressed file or mark a compressed file as compressed, causing automatic decompression on read. The primary use of fiocompress is to compress files in the boot archive.
Note that this utility is not a Committed interface. See attributes(5).
The following options are supported:
Specify a block size for compression. The default block size is 8192.
Compress the specified file.
Decompress the specified file.
Mark the compressed file for automatic decompression on read. Can be used only in conjunction with -c.
The command completed successfully.
The command exited due to an error.
See attributes(5) for descriptions of the following attributes:
This compression/decompression utility works only with files stored in a UFS file system.
There is no obvious way to determine whether a given file is compressed, other than copying the file and comparing the number of disk blocks of the copy against the original.