|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- merge or add total accounting files
/usr/lib/acct/acctmerg [-a] [-i] [-p] [-t] [-u] [-v] [filename] ...
acctmerg reads its standard input and up to nine additional files, all in the tacct format (see acct.h(3HEAD)) or an ASCII version thereof. It merges these inputs by adding records whose keys (normally user ID and name) are identical, and expects the inputs to be sorted on those keys.
Produce output in ASCII version of tacct.
Produce input in ASCII version of tacct.
Print input with no processing.
Produce a single record that totals all input.
Summarize by user ID, rather than by user ID and name.
Produce output in verbose ASCII format, with more precise notation for floating-point numbers.
Example 1 Using the acctmerg command.
The following sequence is useful for making "repairs" to any file kept in this format:
example% acctmerg -v <filename1 >filename2
Edit filename2 as you want:
example% acctmerg -i <filename2 >filename1
See attributes(5) for descriptions of the following attributes: