|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- verifies device accessibility
/usr/bin/getvol -n [-l label] device
/usr/bin/getvol [-f | -F] [-ow] [-l label | -x label] device
getvol verifies that the specified device is accessible and that a volume of the appropriate medium has been inserted. The command is interactive and displays instructional prompts, describes errors, and shows required label information.
The following options are supported:
Runs the command in non-interactive mode. The volume is assumed to be inserted upon command invocation.
Specifies that the label label must exist on the inserted volume (can be overridden by the -o option).
Formats the volume after insertion, using the format command defined for this device in the device table.
Formats the volume after insertion and places a file system on the device. Also uses the format command defined for this device in the device table.
Allows the administrator to override a label check.
Allows administrator to write a new label on the device. User is prompted to supply the label text. This option is ineffective if the -n option is enabled.
Specifies that the label label must exist on the device. This option should be used in place of the -l option when the label can only be verified by visual means. Use of the option causes a message to be displayed asking the administrator to visually verify that the label is indeed label.
The following operands are supported:
Specifies the device to be verified for accessibility.
The following exit values are returned:
Command syntax was incorrect, invalid option was used, or an internal error occurred.
Device table could not be opened for reading.
See attributes(5) for descriptions of the following attributes:
This command uses the device table to determine the characteristics of the device when performing the volume label checking.