|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- make a dbm file, or get a text file from a dbm file
makedbm [-b] [-l] [-s] [-E] [-i yp_input_file] [-o yp_output_name] [-d yp_domain_name] [-m yp_master_name] [-S delimiter] [-D number_of_delimiters] infile outfile
makedbm [-u dbmfilename]
The makedbm utility takes the infile and converts it to a pair of files in ndbm format (see ndbm(3C)), namely outfile.pag and outfile.dir. Each line of the input file is converted to a single dbm record. All characters up to the first TAB or SPACE form the key, and the rest of the line is the data. If a line ends with `\' (backslash), the data for that record is continued on to the next line. makedbm does not treat `#' (pound-sign) as a special character.
Because makedbm is mainly used in generating dbm files for the NIS name service, it generates a special entry with the key yp_last_modified, which is the date of infile (or the current time, if infile is `-'). The entries that have keys with the prefix yp_ are interpreted by NIS server utilities.
The following options are supported:
Insert the YP_INTERDOMAIN into the output. This key causes ypserv(1M) to use DNS for host name and address lookups for hosts not found in the maps.
Create a special entry with the key yp_domain_name.
Specify number_of_delimiters to skip before forming the key.
Delimiters are escaped.
Create a special entry with the key yp_input_file.
Lower case. Convert the keys of the given map to lower case, so that, for example, host name matches succeed independent of upper or lower case distinctions.
Create a special entry with the key yp_master_name. If no master host name is specified, yp_master_name is set to the local host name.
Create a special entry with the key yp_output_name.
Secure map. Accept connections from secure NIS networks only.
Specify the delimiter to use instead of the default delimiter for forming the key.
Undo a dbm file. Prints out the file in text format, one entry per line, with a single space separating keys from values.
The following operands are supported:
Input file for makedbm. If infile is `-' (dash), the standard input is read.
One of two output files in ndbm format: outfile.pag and outfile.dir.
See attributes(5) for descriptions of the following attributes: