|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- Live Upgrade pre-flight check
usr/sbin/lupc [-s] [-U | --ufs2ufs -m mount_point:device:fs_options[:zonename] [-m...]] [-h]
usr/sbin/lupc [-s] [-u | --ufs2zfs -m mount_point:device:fs_options[:zonename] [-m...]] [-D file_system] -p zfs_root_pool] [-h]
usr/sbin/lupc [-s] [-Z | --zfs2zfs [-p zfs_root_pool]] [-h]
The lupc (Live Upgrade pre-flight check) tool performs a number of checks to detect issues in system configuration that might cause a Live Upgrade (LU) operation to fail. This tool should be run before invoking lucreate(1M) command to create a boot environment (BE).
The following options are supported:
Perform the system check on the system.
Indicates user is creating UFS root BE from existing UFS root BE.
Indicates user is creating ZFS root BE from existing UFS root BE.
Indicates user is creating ZFS root BE from existing ZFS root BE.
Valid values for file_system are /var or any other mount point not containing OS deliverables. For example, /data.
mount_point can be any valid mount point or - (hyphen), indicating a swap partition. The device field can be:
The name of a disk slice, of the form /dev/dsk/cnumtnumdnumsnum.
The name of a Solaris Volume Manager volume, of the form /dev/md/dsk/dnum.
The name of a Veritas volume, of the form /dev/vx/dsk/dgname/volname.
The fs_option field can be one the keywords listed below.
Create the file system as a UFS.
Create the file system as a Veritas device.
Create the ZFS dataset.
The optional zonename field specifies the name of an installed non-global zone. It is used to specify a separate file system that belongs to the particular zone, named zonename, that exists in the new BE being created.
Specifies the ZFS pool in which a new BE will reside.
Print command usage.
Error due to incorrect system configuration.
See attributes(5) for descriptions of the following attributes: