|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- configure the PGX32 (Raptor GFX) Graphics Accelerator
/usr/sbin/pgxconfig [-dev device-filename] [-res video-mode [try | noconfirm | nocheck]] [-file machine | system] [-depth 8 | 24] [-24only true | false] [-cachedpixmap true | false] [-defaults]
/usr/sbin/pgxconfig [-propt] [-prconf]
/usr/sbin/pgxconfig [-help] [-res ?]
The pgxconfig utility configures the PGX32 (Raptor GFX) Graphics Accelerator and some of the X11 window system defaults for PGX32 (Raptor GFX). A previous version of this utility was named GFXconfig.
The first form of pgxconfig shown in the synopsis above stores the specified options in the OWconfig file. These options are used to initialize the PGX32 (Raptor GFX) device the next time the window system is run on that device. Updating options in the OWconfig file provides persistence of these options across window system sessions and system reboots.
The second, third, and fourth forms, which invoke only the -prconf, -propt, -help, and -res ? options, do not update the OWconfig file. For the third form all other options are ignored.
The -i option starts pgxconfig in interactive mode.
Options may be specified for only one PGX32 (Raptor GFX) device at a time.
Only PGX32 (Raptor GFX)-specific options can be specified through pgxconfig. The normal window system options for specifying default depth, default visual class and so forth are still specified as device modifiers on the openwin command line. See the Xsun(1) manual page available with the SUNWxwman package.
The user can also specify the OWconfig file that is to be updated. By default, the machine-specific file in the /usr/openwin directory tree is updated. The -file option can be used to specify an alternate file to use. For example, the system-global OWconfig file in the /etc/openwin directory tree can be updated instead.
Both of these standard OWconfig files can only be written by root.
The following options are supported:
When set to false, it forces the PGX32 (Raptor GFX) device to use 24–bit only when running OpenWindows. The default value is true.
Certain applications make use of a cached pixmap when writing to the display device. Such a technique can cause garbled output and can cause the X server to crash. If you experience such behavior, try setting the -cachedpixmap option to false.
Reset all option values to their default values.
Sets the screen depth to 8 or 24 bits per pixel. 24 bits per pixel enables TrueColor graphics in the window system.
Specify the PGX32 (Raptor GFX) special file. The default is /dev/fbs/gfxp0, or /dev/fbs/raptor0 if applicable.
Specifies which OWconfig file to update. If machine is specified, the machine-specific OWconfig file in the /etc/openwin directory tree is updated. If system is specified, the global OWconfig file in the /usr/openwin directory tree is updated. If the specified file does not exist, it is created. This option has no effect unless other options are specified. The default is machine.
Print a list of the pgxconfig command line options, along with a brief explanation of each.
Start pgxconfig in interactive mode.
Print the PGX32 (Raptor GFX) hardware configuration. Thie following is a typical display:
--- Hardware Configuration for /dev/fbs/gfxp0 --- DAC: version 0x0 Type: Board: PROM: version 0x0 PROM Information: RAM: EDID Data: Monitor Sense ID: Card possible resolutions: 640x480x60, 800x600x75, 1024x768x60 1024x768x70, 1024x768x75, 1280x1024x75, 1280x1024x76 1280x1024x60, 1152x900x66, 1152x900x76, 1280x1024x67 960x680x112S, 960x680x108S, 640x480x60i, 768x575x50i, 1280x800x76, 1440x900x76, 1600x1000x66, 1600x1000x76, vga, svga, 1152, 1280, stereo, ntsc, pal Monitor possible resolutions: 720x400x70, 720x400x88, 640x480x60 640x480x67, 640x480x72, 640x480x75, 800x600x56, 800x600x60, 800x600x72, 800x600x75, 832x624x75, 1024x768x87, 1024x768x60, 1024x768x70, 1024x768x75, 1280x1024x75, 1280x1024x76, 1152x900x66, 1152x900x76, 1280x1024x67, 960x680x112S, vga, svga, 1152, 1280 stereo Current resolution setting: 1280x1024x76 Possible depths: 8, 24, 8+24 Current depth: 8
Print the current values of all PGX32 (Raptor GFX) options in the OWconfig file specified by the -file option for the device specified by the -dev option. Print the values of options as they would be in the OWconfig file after the call to pgxconfig would have completed. The following is a typical display:
--- OpenWindows Configuration for /dev/fbs/gfxp0 --- OWconfig: machine Video Mode: not set Depth: 8+24
Specify the built-in video mode used to drive the monitor connected to the specified PGX32 (Raptor GFX) device.
The format for video-mode can be one of the following:
The width is the screen width in pixels, height is the screen height in pixels, and rate is the vertical frequency of the screen refresh. As a convenience, -res also accepts formats with @ prepended to the refresh rate rather than x. For example: 1280x1024@76. The list can be obtained by running pgxconfig with the -res ? option (the third form shown in the command synopsis above). Note that not all resolutions are supported by both the video board and by the monitor. The pgxconfig utility will not permit you to set a resolution not supported by the board unless the noconfirm or nocheck option is specified. It will also request confirmation before setting a resolution not supported by the monitor if the nocheck option is not specified.
For convenience, the video modes listed below have symbolic names defined. Rather than the form widthxheightxrate, the symbolic name may be supplied as the argument to -res. If the symbolic name is none, the screen resolution will be the video mode that is currently programmed in the device when the window system is run.
default console resolution
The -res option also accepts additional, optional arguments immediately following the video mode specification. Any or all of these may be present.
Using the -res option, the user could put the system into an unusable state, a state where there is no video output. This can happen if there is ambiguity in the monitor sense codes for the particular code read. To reduce the chance of this occurring, the default behavior of pgxconfig is to print a warning message to this effect and to prompt the user to find out if it is okay to continue. The noconfirm option instructs pgxconfig to bypass this confirmation and to program the requested video mode anyway. This option is useful when pgxconfig is being run from a shell script.
If present, normal error checking based on the monitor sense code is suspended. The video mode specified by the user will be accepted regardless of whether it is appropriate for the currently attached monitor. (This option is useful if a different monitor is to be connected to the PGX32 (Raptor GFX) device). Use of this option implies noconfirm as well.
This option allows the user to test the specified resolution before committing it. It displays a pattern on the screen with the specified resolution. If the test pattern appears correctly, the user may answer "y" to the query. The other permissable answer is "n".
This sub-option should not be used with pgxconfig while the configured device is being used (for example, while running the window system) as unpredictable results may occur. To run pgxconfig with the try sub-option, the window system should be brought down first.
Print the list of possible resolutions supported by the PGX32 and the monitor.
Force the PGX32 (Raptor GFX) device to use 24 bit only when running Openwindows.
For a given invocation of pgxconfig, if an option does not appear on the command line, the corresponding OWconfig option is not updated; it retains its previous value, except for -depth and -24only.
A default value is used if a PGX32 (Raptor GFX) option has not been specified with pgxconfig when the window system is run. The option defaults are as follows:
The default of none for the -res option indicates that when the window system is run, the screen resolution will be the video mode that is currently programmed in the device.
Example 1 Switching the Resolution on the Monitor Type
The following example switches the monitor type to the resolution of 1280 x 1024 at 76 Hz:
example# /usr/sbin/pgxconfig -res 1280x1024x76
device special file
system configuration file
machine configuration file
PGX32 Installation Manual