|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- install a client key for WAN boot
/usr/lib/inet/wanboot/ickey [-d] [-o type=3des]
/usr/lib/inet/wanboot/ickey [-d] [-o type=aes]
/usr/lib/inet/wanboot/ickey [-d] [-o type=sha1]
The ickey command is used to install WAN boot keys on a running UNIX system so that they can be used the next time the system is installed. You can store three different types of keys: 3DES and AES for encryption and an HMAC SHA-1 key for hashed verification.
ickey reads the key from standard input using getpass(3C) so that it does not appear on the command line. When installing keys on a remote system, you must take proper precautions to ensure that any keying materials are kept confidential. At a minimum, use ssh(1) to prevent interception of data in transit.
Keys are expected to be presented as strings of hexadecimal digits; they can (but need not) be preceeded by a 0x or 0X.
The ickey command has a single option, described below. An argument of the type -o type=keytype is required.
The ickey command the following option.
Delete the key specified by the keytype argument.
On success, ickey exits with status 0; if a problem occurs, a diagnostic message is printed and ickey exits with non-zero status.
WAN boot key storage driver
See attributes(5) for descriptions of the following attributes: