|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- install the Solaris operating system
install-solaris invokes the Solaris Install program. Depending on graphical capability and available memory at the time of invocation, install-solaris invokes either a text-based installer or a graphical installer.
For both SPARC and x86 machines, while you can install on a system with 512 KB of physical memory, 1 GB is the preferred minimum. Memory requirements vary depending on the applications being used, system configurations, and the number of clients or users you will be supporting.
In some cases, even if the minimum physical memory is present, available virtual memory after system startup can limit the number of features available.
install-solaris exists only on the Solaris installation media (CD or DVD) and should be invoked only from there. Refer to the for more details.
install-solaris allows installation of the operating system onto any standalone system. install-solaris loads the software available on the installation media. Refer to the Oracle Solaris 10 8/11 Installation Guide: Basic Installations for disk space requirements.
Refer to the Oracle Solaris 10 8/11 Installation Guide: Basic Installations for more information on the various menus and selections.
See attributes(5) for descriptions of the following attributes:
It is advisable to exit install-solaris by means of the exit options in the install-solaris menus.