|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- file system consistency check and interactive repair
fsck -F pcfs [generic_options] special
fsck -F pcfs [generic_options] [-o specific_options] special
The fsck utility audits and interactively repairs inconsistent conditions on file systems. special represents the character special device on which the file system resides, for example /dev/rdiskette. The character special device, not the block special device, should be used.
In the case of correcting serious inconsistencies, by default, fsck asks for confirmation before making a repair and waits for the operator to respond either yes or no. If the operator does not have write permission on the file system, fsck defaults to a -n (no corrections) action. See fsck(1M).
Repairing some file system inconsistencies may result in loss of data. The amount and severity of data loss may be determined from the diagnostic output.
When executed with the verify option (-o v), fsck_pcfs automatically scans the entire file system to verify that all of its allocation units are accessible. If it finds any units inaccessible, it updates the file allocation table (FAT) appropriately. It also updates any effected directory entries to reflect the problem. This directory update includes truncating the file at the point in its allocation chain where the file data is no longer accessible. Any remaining accessible allocation units become orphaned.
Orphaned chains of accessible allocation units are, with the operator's concurrence, linked back into the file system as files in the root directory. These files are assigned names of the form fileNNNN.chk, where the Ns are digits in the integral range from 0 through 9.
After successfully scanning and correcting any errors in the file system, fsck displays a summary of information about the file system. This summary includes the size of the file system in bytes, the number of bytes used in directories and individual files, and the number of available allocation units remaining in the file system.
The following generic options are supported:
Check but do not repair. This option checks that the file system is suitable for mounting, returning the appropriate exit status. If the file system is ready for mounting, fsck displays a message such as:
pcfs fsck: sanity check: /dev/rdiskette okay
Assume a no response to all questions asked by fsck; do not open the file system for writing.
Echo the expanded command line, but do not execute the command. This option may be used to verify and to validate the command line.
Assume a yes response to all questions asked by fsck.
Specify pcfs file system specific options in a comma-separated list, in any combination, with no intervening spaces.
Verify all allocation units are accessible prior to correcting inconsistencies in the metadata.
Check and fix the file system non-interactively (preen). Exit immediately if there is a problem requiring intervention.
Check writable file systems only.
The device which contains the pcfs. The device name for a diskette is specified as /dev/rdiskette0 for the first diskette drive, or /dev/rdiskette1 for a second diskette drive. A hard disk device or high-capacity removable device name much be qualified with a suffix to indicate the proper FDISK partition.
For example, in the names: /dev/rdsk/c0t0d0p0:c and /dev/rdsk/c0t4d0s2:c, the :c suffix indicates the first partition on the disk contains the pcfs.
See attributes(5) for descriptions of the following attributes:
The operating system buffers file system data. Running fsck on a mounted file system can cause the operating system's buffers to become out of date with respect to the disk. For this reason, the file system should be unmounted when fsck is used. If this is not possible, care should be taken that the system is quiescent and that it is rebooted immediately after fsck is run. Quite often, however, this is not sufficient. A panic will probably occur if running fsck on a file system modifies the file system.