|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- atomic operations
This collection of functions provides atomic memory operations. There are 8 different classes of atomic operations:
These functions provide an atomic addition of a signed value to a variable.
These functions provide an atomic logical 'and' of a value to a variable.
These functions provide atomic bit setting and clearing within a variable.
These functions provide an atomic comparison of a value with a variable. If the comparison is equal, then swap in a new value for the variable, returning the old value of the variable in either case.
These functions provide an atomic decrement on a variable.
These functions provide an atomic increment on a variable.
These functions provide an atomic logical 'or' of a value to a variable.
These functions provide an atomic swap of a value with a variable, returning the old value of the variable.
See attributes(5) for descriptions of the following attributes:
Atomic instructions ensure global visibility of atomically-modified variables on completion. In a relaxed store order system, this does not guarantee that the visibility of other variables will be synchronized with the completion of the atomic instruction. If such synchronization is required, memory barrier instructions must be used. See membar_ops(9F).
Atomic instructions can be expensive. since they require synchronization to occur at a hardware level. This means they should be used with care to ensure that forcing hardware level synchronization occurs a minimum number of times. For example, if you have several variables that need to be incremented as a group, and each needs to be done atomically, then do so with a mutex lock protecting all of them being incremented rather than using the atomic_inc(9F) operation on each of them.