|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- return mapped virtual address
#include <sys/pccard.h> int32_t csx_GetMappedAddr(acc_handle_t handle, void **addr);
Solaris DDI Specific (Solaris DDI)
The virtual or I/O port number represented by the handle.
This function returns the mapped virtual address or the mapped I/O port number represented by the handle, handle.
The resulting address or I/O port number can be directly accessed by the caller.
The resulting address or I/O port number can not be directly accessed by the caller; the caller must make all accesses to the mapped area via the common access functions.
No PCMCIA hardware installed.
This function may be called from user, kernel, or interrupt context.
PC Card 95 Standard, PCMCIA/JEIDA