|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- free previously allocated memory
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_dma_mem_free(ddi_acc_handle_t *handlep);
Pointer to the data access handle previously allocated by a call to ddi_dma_mem_alloc(9F).
Solaris DDI specific (Solaris DDI).
ddi_dma_mem_free() deallocates the memory acquired by ddi_dma_mem_alloc(9F). In addition, it destroys the data access handle handlep associated with the memory.
ddi_dma_mem_free() can be called from user, kernel, or interrupt context.