|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- convert device sizes
#include <sys/pccard.h> int32_t csx_ConvertSize(convert_size_t *cs);
Solaris DDI Specific (Solaris DDI)
Pointer to a convert_size_t structure.
csx_ConvertSize() is a Solaris-specific extension that provides a method for clients to convert from one type of device size representation to another, that is, from devsize format to bytes and vice versa.
The structure members of convert_size_t are:
uint32_t Attributes; uint32_t bytes; uint32_t devsize;
The fields are defined as follows:
This is a bit-mapped field that identifies the type of size conversion to be performed. The field is defined as follows:
Converts bytes to devsize format.
Converts devsize format to bytes.
If CONVERT_BYTES_TO_DEVSIZE is set, the value in the bytes field is converted to a devsize format and returned in the devsize field.
If CONVERT_DEVSIZE_TO_BYTES is set, the value in the devsize field is converted to a bytes value and returned in the bytes field.
Invalid bytes or devsize.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PCCard 95 Standard, PCMCIA/JEIDA