|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- utility for SCSI target drivers to establish the presence of a target
#include <sys/scsi/scsi.h> int scsi_slave(struct scsi_device *devp, int (*callback)(void));
The scsi_slave() function is obsolete. This function has been replaced by scsi_probe(9F).
Pointer to a scsi_device(9S) structure.
Pointer to a callback function, NULL_FUNC or SLEEP_FUNC.
scsi_slave() checks for the presence of a SCSI device. Target drivers may use this function in their probe(9E) routines. scsi_slave() determines if the device is present by using a Test Unit Ready command followed by an Inquiry command. If scsi_slave() is successful, it will fill in the scsi_inquiry structure, which is the sd_inq member of the scsi_device(9S) structure, and return SCSI_PROBE_EXISTS. This information can be used to determine if the target driver has probed the correct SCSI device type. callback indicates what the allocator routines should do when DMA resources are not available:
Do not wait for resources. Return a NULL pointer.
Wait indefinitely for resources.
callback points to a function which is called when resources may have become available. callback must return either 0 (indicating that it attempted to allocate resources but again failed to do so), in which case it is put back on a list to be called again later, or 1 indicating either success in allocating resources or indicating that it no longer cares for a retry.
No space available for structures.
Device exists and inquiry data is valid.
Device exists but inquiry data is not valid.
Polled command failure.
No response to TEST UNIT READY.
scsi_slave() is normally called from the target driver's probe(9E) or attach(9E) routine. In any case, this routine should not be called from interrupt context, because it can sleep waiting for memory to be allocated.
See attributes(5) for a description of the following attributes:
ANSI Small Computer System Interface-2 (SCSI-2)
The scsi_slave() function is obsolete and will be discontinued in a future release. This function has been replaced by scsi_probe(9F).