|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- return the number of clock ticks since boot
#include <sys/types.h> #include <sys/ddi.h> #include <sys/sunddi.h> clock_t ddi_get_lbolt(void);
Solaris DDI specific (Solaris DDI).
The ddi_get_lbolt() function returns a value that represents the number of clock ticks since the system booted. This value is used as a counter or timer inside the system kernel. The tick frequency can be determined by using drv_usectohz(9F), which converts microseconds into clock ticks.
The ddi_get_lbolt64() behaves essentially the same as ddi_get_lbolt(), except the value is returned in a longer data type (int64_t) that will not wrap for 2.9 billion years.
The ddi_get_lbolt() function returns the number of clock ticks since boot in a clock_t type.
The ddi_get_lbolt64() function returns the number of clock ticks since boot in a int64_t type.
These routines can be called from any context.