|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library|
- add a hook to be called in event processing
#include <sys/neti.h> int net_hook_unregister(net_handle_t net, char *hook_name, hook_t hook);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_register().
hook name to be registered
pointer to a hook_t structure
The net_hook_register() function uses hooks that allow callbacks to be registered with events that belong to a network protocol. A successful call to net_hook_register() requires that a valid handle for a network protocol be provided (the net parameter), along with a hook description that includes a reference to an available event.
While it is possible to use the same hook_t structure with multiple calls to net_hook_register(), it is not encouraged.
The hook_t structure passed in with this function is described by hook_t(9S). The following describes how this structure is used.
Must be non-NULL and represent a function that fits the specified interface.
Gives the hook a name that represents its owner. No duplication of h_name among the hooks present for an event is allowed.
Currently unused and must be set to 0.
Specify a hint to net_hook_register() on how to insert this hook. If the hint cannot be specified, then an error is returned.
May take any value that the consumer wishes to have passed back when the hook is activated.
If the net_hook_register() function succeeds, 0 is returned. Otherwise, one of the following errors is returned:
The system cannot allocate any more memory to support registering this hook.
A hook cannot be found among the given family of events.
A hook with the given h_name already exists on that event.
A before or after dependency cannot be satisfied due to the hook with
The h_hint field specifies a hint that cannot currently be satisfied because it conflicts with another hook. An example of this might be specifying HH_FIRST or HH_LAST when another hook has already been registered with this value.
The net_hook_register() function may be called from user or kernel context.
See attributes(5) for descriptions of the following attributes: