|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- initialize a buffer structure
#include <sys/ddi.h> #include <sys/sunddi.h> void bioinit(struct buf *bp);
Solaris DDI specific (Solaris DDI).
Pointer to the buffer header structure.
The bioinit() function initializes a buf(9S) structure. A buffer structure contains state information which has to be initialized if the memory for the buffer was allocated using kmem_alloc(9F). This is not necessary for a buffer allocated using getrbuf(9F) because getrbuf() will call bioinit() directly.
The bioinit() function can be called from any context.
Example 1 Using bioinit()
struct buf *bp = kmem_alloc(biosize(), KM_SLEEP); bioinit(bp); /* use buffer */