|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- remove an NDI event service callback
#include <sys/ddi_obsolete.h> int ldi_remove_event_handler(ldi_handle_t lh, ldi_callback_id_t id);
Layered handle representing the device for which the event notification is requested.
Unique system-wide registration ID returned by ldi_add_event_handler(9F) upon successful registration.
This function is obsolete and is only maintained for compatibility. Use of this function is strongly discouraged. For equivalent functionality provided by new interfaces, see ldi_ev_register_callbacks(9F) and ldi_ev_remove_callbacks(9F).
The ldi_remove_event_handler() function removes the callback handler specified by the registration ID (ldi_callback_id_t). Upon successful removal, the callback handler is removed from the system and is not invoked at the event occurance.
Callback handler removed successfully.
Failed to remove callback handler.
This function can be called from user and kernel contexts only.