|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- set the timeout value for the context management callback
#include <sys/ddi.h> #include <sys/sunddi.h> void devmap_set_ctx_timeout(devmap_cookie_t dhp, clock_t ticks);
Solaris DDI specific (Solaris DDI).
An opaque mapping handle that the system uses to describe the mapping.
Number of clock ticks to wait between successive calls to the context management callback function.
The devmap_set_ctx_timeout() function specifies the time interval for the system to wait between successive calls to the driver's context management callback function, devmap_contextmgt(9E).
Device drivers typically call devmap_set_ctx_timeout() in the devmap_map(9E) routine. If the drivers do not call devmap_set_ctx_timeout() to set the timeout value, the default timeout value of 0 will result in no delay between successive calls to the driver's devmap_contextmgt(9E) callback function.
The devmap_set_ctx_timeout() function can be called from user, interrupt, or kernel context.