|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- create and initialize a new kstat for a specific instance of IP
#include <sys/types.h> #include <sys/kstat.h> #include <sys/neti.h> kstat_t *net_kstat_create(netid_t netid, char *module, int instance, char *name, char *class, uchar_type type, ulong_t ndata, uchar_t ks_flag);
Solaris DDI specific (Solaris DDI).
IP instance identifier.
The name of the provider's module (such as “sd”, “esp”, ...). The “core” kernel uses the name “unix”.
The provider's instance number, as from ddi_get_instance(9F). Modules which do not have a meaningful instance number should use 0.
A pointer to a string that uniquely identifies this structure. Only KSTAT_STRLEN - 1 characters are significant.
The general class that this kstat belongs to. The following classes are currently in use: disk, tape, net, controller, vm, kvm, hat, streams, kstat, and misc.
The type of kstat to allocate. Valid types are:
Allows more than one data record per kstat.
Interrupt; only one data record per kstat.
I/O; only one data record per kstat
The number of type-specific data records to allocate.
A bit-field of various flags for this kstat. ks_flag is some combination of:
Tells kstat_create() not to allocate memory for the kstat data section; instead, the driver will set the ks_data field to point to the data it wishes to export. This provides a convenient way to export existing data structures.
Makes the kstat data section writable by root.
Indicates that this kstat is to be persistent over time. For persistent kstats, kstat_delete(9F) simply marks the kstat as dormant; a subsequent kstat_create() reactivates the kstat. This feature is provided so that statistics are not lost across driver close/open (such as raw disk I/O on a disk with no mounted partitions.) Note: Persistent kstats cannot be virtual, since ks_data points to garbage as soon as the driver goes away.
If successful, net_kstat_create() returns a pointer to the allocated kstat. NULL is returned upon failure.
The net_kstat_create() function may be called from user or kernel context.
See attributes(5) for descriptions of the following attributes: