|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- free a hook_t data structure
#include <sys/hook.h> void hook_free(hook_t * hook);
Solaris DDI specific (Solaris DDI).
pointer returned by hook_alloc(9F).
The hook_free() function frees a hook_t structure that was originally allocated by hook_alloc(9F).
The hook_free() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: