|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- notify target driver of bus resets
#include <sys/scsi/scsi.h> void scsi_reset_notify(struct scsi_address *ap, int flag, void (*callback)(caddr_t), caddr_t arg);
Solaris DDI specific (Solaris DDI).
Pointer to the scsi_address structure.
A flag indicating registration or cancellation of the notification request.
A pointer to the target driver's reset notification function.
The callback function argument.
The scsi_reset_notify() function is used by a target driver when it needs to be notified of a bus reset. The bus reset could be issued by the transport layer (e.g. the host bus adapter (HBA) driver or controller) or by another initiator.
The argument flag is used to register or cancel the notification. The supported values for flag are as follows:
Register callback as the reset notification function for the target driver.
Cancel the reset notification request.
Target drivers can find out whether the HBA driver and controller support reset notification by checking the reset-notification capability using the scsi_ifgetcap(9F) function.
If flag is SCSI_RESET_NOTIFY, scsi_reset_notify() returns:
The notification request has been accepted.
The transport layer does not support reset notification or could not accept this request.
If flag is SCSI_RESET_CANCEL, scsi_reset_notify() returns:
The notification request has been canceled.
No notification request was registered.
The scsi_reset_notify() function can be called from user, interrupt, or kernel context.