|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- get pointer to the read queue
#include <sys/stream.h> #include <sys/ddi.h> queue_t *RD(queue_t *q);
Architecture independent level 1 (DDI/DKI).
Pointer to the write queue whose read queue is to be returned.
The RD() function accepts a write queue pointer as an argument and returns a pointer to the read queue of the same module.
CAUTION: Make sure the argument to this function is a pointer to a write queue. RD() will not check for queue type, and a system panic could result if it is not the right type.
The pointer to the read queue.
The RD() function can be called from user, interrupt, or kernel context.
Example 1 Function page reference
See the qreply(9F) function page for an example of RD().