|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- easier DMA setup for use with buffer structures
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_buf_setup(dev_info_t *dip, struct buf *bp, uint_t flags, int (*waitfp) (caddr_t),, caddr_t arg, ddi_dma_lim_t *lim, ddi_dma_handle_t *handlep);
This interface is obsolete. ddi_dma_buf_bind_handle(9F) should be used instead.
A pointer to the device's dev_info structure.
A pointer to a system buffer structure (see buf(9S)).
Flags that go into a ddi_dma_req structure (see ddi_dma_req(9S)).
The address of a function to call back later if resources aren't available now. The special function addresses DDI_DMA_SLEEP and DDI_DMA_DONTWAIT (see ddi_dma_req(9S)) are taken to mean, respectively, wait until resources are available, or do not wait at all and do not schedule a callback.
Argument to be passed to a callback function, if such a function is specified.
Pointer to a DMA handle. See ddi_dma_setup(9F) for a discussion of handle.
The ddi_dma_buf_setup() function is an interface to ddi_dma_setup(9F). It uses its arguments to construct an appropriate ddi_dma_req structure and calls ddi_dma_setup() with it.
See ddi_dma_setup(9F) for the possible return values for this function.
The ddi_dma_buf_setup() function can be called from user, interrupt, or kernel context, except when waitfp is set to DDI_DMA_SLEEP, in which case it cannot be called from interrupt context.
See attributes(5) for a description of the following attributes: